Jump to content
liam.1995

Fuel pressure drop

Recommended Posts

Hi all, been having an issue with a slow start of the engine. It does start after cranking for a few seconds. Also when accelerating the car seems to struggle or lose power. 

 

I know the fuel pressure is dropping when the engine is off. As I have put a gauge on the fuel rail and the pressure drops. 

 

Now for the bit that’s confusing me. If I clamp the return pipe the pressure still drops. But when I clamp the supply line the pressure doesn’t drop. There doesn’t seem to be any fuel leaks in the system. And I have fitted an extra inline check valve in the supply line.  

 

Many advise would be great 

Share this post


Link to post
Share on other sites

Hey Liam, have you solved that issue? I'm experiencing the exact same. It goes up to 4bar but then it drops immediately. Please somebody help us!

Share this post


Link to post
Share on other sites

Thanks for such a quick reply! I found that my retainer clips are broken, so I have the filter being held with zip ties. I'll install new clips and check again. 

 

Where was your bad connection, do you know? Perhaps it's somewhere else and I'll have to pull the fuel pump or something...

 

Conrad

Share this post


Link to post
Share on other sites
29 minutes ago, liam.1995 said:

It was on the ridged fuel pipe under the car. Had to cut a piece out and put an smc push fitting it. Worked a treat. 

Awesome, I'll give it a try and let you know how it goes! Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×